Instrument lights and blinker light not working

Have a Lucas question?

Instrument lights and blinker light not working

Postby fgoettsche » Mon Jun 30, 2014 9:12 am

Hi everyone,

As I explained in another post I've recently acquired a MK1 Bugeye, and I'm trying to fix all the little problems it came with.

Everything electrical works, except the gauge lights and the turn signal indicator.
Where could I look for possible culprits?

By the way, the little Ignition and Highbeam lights inside the gauges work fine.


Thanks in advance, and happy Spriteing!
fgoettsche
Pit Crew
 
Posts: 15
Joined: Tue Jun 10, 2014 9:02 am

Re: Instrument lights and blinker light not working

Postby peter an5l » Mon Jun 30, 2014 1:34 pm

Hi, there is a tiny little switch between the main instruments under the dash. Try and find it, switch it and maybe something will come to light. Otherwise check the bulbs.

Piet ( have you got my e-mail ? )
User avatar
peter an5l
1098cc
 
Posts: 410
Joined: Mon Apr 21, 2008 3:05 pm
Location: Bremen, Germany

Re: Instrument lights and blinker light not working

Postby fgoettsche » Mon Jun 30, 2014 3:13 pm

Yes I've tried that but nothing lights up!

It's a bit strange for alle the bulbs to be missing or not working isn't it?

No I don't. I will PM you my address
fgoettsche
Pit Crew
 
Posts: 15
Joined: Tue Jun 10, 2014 9:02 am

Re: Instrument lights and blinker light not working

Postby Charlie Tolman » Tue Jul 01, 2014 1:31 am

Turn light indicator: Check the bulb. Light green wire from flasher. Bad flasher ?

Gauge lights: Red wire from post S on the ignition and light switch, to panel light switch.
Bad switch or switches ? Red-white wire from the panel light switch to gauge lights.

Charlie T.
Charlie Tolman
Judson Supercharged
 
Posts: 1197
Joined: Wed Mar 01, 2006 10:36 am
Location: Minnesota

Re: Instrument lights and blinker light not working

Postby fgoettsche » Tue Jul 01, 2014 2:47 am

Charlie Tolman wrote:Turn light indicator: Check the bulb. Light green wire from flasher. Bad flasher ?

Gauge lights: Red wire from post S on the ignition and light switch, to panel light switch.
Bad switch or switches ? Red-white wire from the panel light switch to gauge lights.

Charlie T.



Your knowledge is incredibly helpful.
I will let you know as soon as I have the chance to take a look.

Thank you Charlie
fgoettsche
Pit Crew
 
Posts: 15
Joined: Tue Jun 10, 2014 9:02 am


Return to Electrical

Who is online

Users browsing this forum: No registered users and 1 guest

cron