tachometer

Have a Lucas question?

tachometer

Postby CaptRandy » Thu Nov 29, 2012 2:44 pm

Having a problem with tach, it does not work. Following the wiring from Haynes manual it appears that the coiled wire(white)goes from the ignition through the coiled area at rear of tach and ultimately to the ignition coil. The green wire goes from the tach rear to the flasher unit and from there to the fuse block. Am I following the wiring correctly? The flasher also controls the direction signals , the horn and the low/high beam light. Can the flasher have one portion bad as the horn, direction signals and low/high beams work? Any ides to look at?
CaptRandy
Pit Crew
 
Posts: 22
Joined: Thu Nov 15, 2012 8:33 pm
Location: Ocean City NJ

Re: tachometer

Postby Jim Gruber » Thu Nov 29, 2012 4:49 pm

Switch will come apart if you take a careful look. Lots of areas for Green to appear. All of the items fed through that switch failed to work when I received Bugsy 12 years ago. A careful cleaning and reassembly and all of my gremlins went away. Same goes for Fan and headlight switch .
Jim Gruber
Dayton, OH
Bugsy - 68 Sprite
Bugeye in Disguise
User avatar
Jim Gruber
1098cc
 
Posts: 295
Joined: Wed Jan 25, 2006 12:36 pm

Re: tachometer

Postby CaptRandy » Thu Nov 29, 2012 5:18 pm

Will treat with a little Corrosion X see if it helps
CaptRandy
Pit Crew
 
Posts: 22
Joined: Thu Nov 15, 2012 8:33 pm
Location: Ocean City NJ

Re: tachometer

Postby CaptRandy » Thu Nov 29, 2012 5:20 pm

Will treat with a little Corrosion X see if it helps
CaptRandy
Pit Crew
 
Posts: 22
Joined: Thu Nov 15, 2012 8:33 pm
Location: Ocean City NJ


Return to Electrical

Who is online

Users browsing this forum: No registered users and 1 guest

cron