Bugeye Flasher

Have a Lucas question?

Bugeye Flasher

Postby Mark McNaught » Sun Feb 10, 2008 1:37 pm

I have a bizarre problem. When I turn the flasher switch either side, the green dash light flashes once, then stops while the signal lights flash normally if a bit more rapidly. Anyone else with this prob?

Mark McNaught
Mark McNaught
Pit Crew
 
Posts: 39
Joined: Thu Feb 15, 2007 10:04 am

Re: Bugeye Flasher

Postby admin » Sun Feb 10, 2008 8:26 pm

Mmmm...interesting. Well, if the lights are flashing sounds like the flasher itself is working. I'd guess a short somewhere in the dash light?

Those things can be frustrating to track down...

d
User avatar
admin
Site Admin
 
Posts: 766
Joined: Fri May 21, 2004 5:44 pm

Re: Bugeye Flasher

Postby Frogarri » Mon Feb 11, 2008 1:20 pm

Mark,

Most likely the flasher unit is going bad. The one post on the flasher can marked "P" (if an original can) is the one that drives/powers the green dash light. The other two posts "B" is power in and "L" is power out to the dash switch. Sounds as if the "P" post gets power and then shorts out. As already pointed out it could be a short in the green/brown wire going to the dash light or a bad ground at the dash light.
Frogarri
'59 Bugeye 'Kermit'
'61 AH Sprite 'Ole Gray' in "The Healey Book"
http://sprites2.homestead.com/
User avatar
Frogarri
1098cc
 
Posts: 420
Joined: Thu May 27, 2004 10:11 pm
Location: Pasadena, Maryland

Got it

Postby Mark McNaught » Sun Mar 02, 2008 1:33 pm

In fact, when I had reinstalled the front running lights, I had reversed the running / flasher terminals, so the load wasn't right. Works correctly now.
Mark McNaught
Pit Crew
 
Posts: 39
Joined: Thu Feb 15, 2007 10:04 am


Return to Electrical

Who is online

Users browsing this forum: No registered users and 1 guest

cron